Microsoft Teams Call Queue Issue

Incident Report for Telesmart Ltd

Monitoring

We have had reports that some of our clients are now able to answer queue calls.

We are monitoring this and reaching out to clients that have been experiencing the issue. If you are still experiencing any issues let us know.
Posted May 02, 2025 - 17:19 NZST

Investigating

Telesmart is currently investigating reports of an intermittent issue where Microsoft Teams call queues fail to properly receive inbound calls, instead triggering an immediate outbound call to the original caller.

We are actively working with Microsoft to identify the root cause and resolve the issue as quickly as possible.

Please contact Telesmart's Help Desk via the channels below if you are experiencing this problem and haven't already logged a ticket.

NZ 0800 835376 (TELESMART)
helpdesk@telesmart.co.nz

AU 1800 316620
helpdesk@telesmart.net.au
Posted May 02, 2025 - 14:25 NZST
This incident affects: Hosted Voice Services (Cloud Calling for Microsoft Teams, Operator Connect for Microsoft Teams).